ProPhoto 3 compatibility plugin

If you are still using ProPhoto 3, and you’ve upgraded to the latest version of WordPress (version 3.3 or higher), then you might have some trouble uploading images. You’ll need to take a few seconds to install a plugin to make sure that P3 works properly with the most recent versions of WordPress.

Do you already have the plugin?

You might simply need to update your existing plugin with the current version – to check this, log into WordPress and go to:
“Plugins” > “Installed Plugins”
This screen shows all your plugins, where you’ll find the “ProPhoto3 Theme Compatibility Patches” plugin listed:

Version number is listed here - be sure you are using version "1005" or greater.

Version number is listed here – be sure you are using version “1005” or greater.

Even if you find the plugin shown here, we recommend you delete it so you can be sure you’re using the latest version. Click to deactivate the plugin. Then, click to delete the plugin so it is totally removed from WordPress.

If you have version 1005 or greater, you should see when updates are available right within WordPress.

Download the plugin

If you don’t see the patch plugin in WordPress at all, or if the version was older than 1005 and you deleted the old version above, you’ll need to download it to your computer and install it in WordPress. Here we go:

Step 1:

Download the plugin zip file WITHOUT unzipping it:

Download Plugin Zip   

Download the plugin zip file to your desktop by clicking the above link. The file will be called pp-p3-compat.latest.zip on your computer.

 NOTE: if your browser (Safari, etc.) automatically unzips the file, you’ll need to download again and RIGHT-CLICK on the link to choose “Download Linked File As…” or “Save Link As…” 

Step 2:

Go to “Plugins” > “Add New” in your WordPress admin area:

plugins-add-new

Step 3:

Click on the “Upload” link:

plugins-upload-link

Step 4:

Choose the zip file you downloaded in Step 1, and click the “Install Now” button:

upload-patch-and-install

Step 5:

Click “Activate Plugin”

plugin-click-to-activate

That’s it! You don’t have to do anything except keep the plugin up to date by allowing WordPress to update it whenever an update is available.  It will handle all future compatibility issues for ProPhoto version 3 and the latest versions of WordPress as they are released.

Having trouble installing the plugin automatically from within WordPress?
Please try uploading the plugin directly to the server using our manual plugin installation guide.

Why do I need this plugin?

As of September 27, 2011, ProPhoto3 is no longer under active development, or available for download, and tech support ended January 7, 2014 with the release of ProPhoto 5.

Any required patches for bug fixes or WordPress version compatibility issues will be handled through this plugin, instead of releasing changes to the ProPhoto 3 software itself.

Releasing compatibility patches as a plugin makes it much, much easier for you as the end user because you can install and update the plugin with just a few clicks, instead of having to go through the process of deleting and re-uploading and re-activating the ProPhoto software through the WordPress theme uploader or FTP every time there is a compatibility issue because of a new version of WordPress.

Consider Upgrading ProPhoto

You’re never required to purchase an upgrade, but ProPhoto is updated to stay current with today’s modern web. New features have been added in the last two releases:

https://legacy-help.pro.photo/whats-new-in-p4/
https://legacy-help.pro.photo/whats-new-in-p5/

You should find your registration ID in your ProPhoto 3 software in this screen:
“Appearance” > “P3 Customize” > “Settings” > “Blog settings” > “P3 Registration”
Use your Transaction ID to upgrade at a discount here:

http://www.prophoto.com/upgrade/

This plugin is only for users of P3 (ProPhoto version 3).
P4 users do not need this plugin. You are not being shown the tutorial because you have not identified yourself as a P3 user. If you are a P3 user, click the “change” link in the wooden strip below next to the “4” graphic.

This plugin is only for users of P3 (ProPhoto version 3).
P5 users do not need this plugin. You are not being shown the tutorial because you have not identified yourself as a P3 user. If you are a P3 user, click the “change” link in the wooden strip below next to the “5” graphic.

If you’ve searched the tutorials and can't find what you need, please contact us. We’re here to help. Contact Us